Oh no my holiday

Anything Triton related

Oh no my holiday

Postby lovestriton on Sat Jan 01, 2022 11:41 am

ML VR 3.2 2008.

2 months ago on warm days it occasionally lost power. By lost power I mean it idles and revs fine,but going up any incline requires gear changes and to hold 100k you need a runway to get to speed, car floored and a flat road. I have been turning car of and on and it went back to working by doing this.

Today with 36deg it has now lost power and the on off trick is not working.

I had to get off the freeway and take back roads cause I'm causing a problem.

I have had it to two mechanics and it pulls no codes and they are not sure of the problem.

The MAP and MAF have been cleaned.

It won't tow a van in its current state and that's a problem right now...

I have a full set of tools with me.

Any ideas collective...
Thanks in advance
lovestriton
 
Posts: 5
Joined: Mon Aug 16, 2021 9:22 am


 

Re: Oh no my holiday

Postby RHKTriton on Sun Jan 02, 2022 5:30 pm

Sounding like lack of fuel.

Have you tried a new fuel filter?

Checked the fuel hoses at the filter?

Intercooler hoses ok?

EGR operating properly?

Little hose and pipe from inlet manifold to MAP sensor clear?

Probably a few other basics to check.

I've got the same model with over 300k on the clock and the only time I lost power was when I stuffed around with boost levels.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4623
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Re: Oh no my holiday

Postby lovestriton on Mon Jan 10, 2022 2:14 pm

Did most of those things thanks. I bought a scangauge it occasionally shows the map sensor goes haywire for a sec. Will source a replacement be see how I go...
lovestriton
 
Posts: 5
Joined: Mon Aug 16, 2021 9:22 am

Re: Oh no my holiday

Postby RHKTriton on Mon Jan 10, 2022 6:28 pm

With all the electrickery these days, it doesn't take much to derail the show.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4623
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests