4wd Light flashing while engaged

Engines, Gearboxes, Transfers, Tailshafts, Diffs, axles and CVs

4wd light flashing not engaging

Postby Bcollins46 on Thu Aug 31, 2017 3:28 pm

the 4wd light is flashing and wont engage when selected [stays flashing] on 2010 triton. have replaced the 2 vacuum valves mounted on lower drivers side firewall and the actuator on the front diff still no luck any ideas ??? thanks
Bcollins46
 
Posts: 2
Joined: Tue Aug 29, 2017 7:02 pm


 

Re: 4wd light flashing not engaging

Postby NowForThe5th on Thu Aug 31, 2017 7:32 pm

Welcome to the forum. You'll find great truth in the well worn adage that Search is your friend.

You'll find that with a better understanding of the system the fact that the light is flashing is because it's telling you that something is wrong. This could be either electrical in the sensor that confirms to the ECU that drive is engaged/disengaged in the front axle or it could be a vacuum issue in that insufficient vacuum is being applied to take the system out of the default 4WD position. You need to start at the front axle and work your way up along the system searching for a split hose, poor joint connection or vacuum pump not working.

I'm going to lock this now and move it a bit later to an applicable, existing thread.
Chris

If work is so terrific, why do they have to pay us to do it?
User avatar
NowForThe5th
Moderator
 
Posts: 8960
Joined: Sun Jun 15, 2008 2:00 pm
Location: Holt, ACT

Re: 4wd Light flashing while engaged

Postby GreenGoblin on Mon Oct 23, 2017 11:08 am

Hi there, I have a broken nipple (the plastic one) on the 4wd actuator on my Ml, and was looking at replacing the actuator unit myself instead of stuffing around trying to glue it back on. It looks like a simple job, just pulling the other hose off the metal nipple on the side then undoing a couple of Bolts that hold the actuator in place. The only tricky part looks to be removing/replacing the pin that holds the 2 sections of actuator rod together. Has anyone done this and can offer any guidance?
GreenGoblin
 
Posts: 2
Joined: Mon Jan 16, 2017 9:37 am

Re: 4wd Light flashing while engaged

Postby ntmntriton on Sat Nov 04, 2017 8:51 am

Mine was flashing since I bought it at 87000ks, put a lift kit in and changed oyt some studs while i was at it, thought I'd buggered a wheel bearing. Took a new hub into mechanic and when I came back he said it was real hard work getting it off, was all rusted. Now no problems with 4wd light.
ntmntriton
 
Posts: 14
Joined: Sun Apr 30, 2017 1:05 am

Re: 4wd Light flashing while engaged

Postby mowerman on Sun Feb 18, 2018 3:46 pm

Hi all. I have the light flashing and no 4wd engaged.
08 ml 3.2 with easy select,I think. Same as my mk, 2h 4h 4l .no c's anywhere.
Friday it worked fine. 4l with a gut full getting off a really soft and powdery beach.
Yesterday I got 50 meters down a soft track w hen the light started to flash and lost 4wd.
2 hrs later got winched out backwards by a Dodge Ram. Very short story.

After a lot ofreading and a bit of testing I have this.
Turn vehicle on the actuator moves in.There is vacuum on that line.Put in 4wd and nothig happens.
No vacuum on the other line but still vacuum on the first line.

At least 1 selloniod is working but it won't turn off or the other one on when 4wd is engaged.

Switch maybe?
Which switch? Where?

Rod.
mowerman
 
Posts: 13
Joined: Fri Mar 04, 2016 4:09 pm

Re: 4wd Light flashing while engaged

Postby RHKTriton on Sun Feb 18, 2018 6:50 pm

So if the issue has presented itself since your 'sandy' situation, I'd be inclined to think some mechanic trauma has occurred to a vacuum line or electrical wiring.

You may have to trace the hoses between the actuator and solenoids.

Could swap the solenoids, engage 4wd and see if actuator kicks in

Check fuses, voltage at solenoids, etc.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4557
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Re: 4wd Light flashing while engaged

Postby Snooozy on Wed Feb 21, 2018 8:33 pm

the 4x4 dis-engages in the diff, so yes the CV will rotate as it's connected directly to the wheel hub
User avatar
Snooozy
Platinum Subscriber
 
Posts: 3856
Joined: Sat Jun 27, 2009 12:27 am
Location: Victoria

Re: 4wd Light flashing while engaged

Postby mowerman on Sat Feb 24, 2018 11:42 am

OK
Put a new set of solenoids in.
Actuator taken out.Tested, works fine.Greased and put back in.
Now have 4wd occasionally. Not all the time.
Idling in 4wd the light will be solid then flicker, solid then flash for a bit then flicker.
Watching the actuator when in 4wd, the shaft goes in and out faster than you can say it.
And again.........
WTF.
Also takes a while for the shaft to come out when the vehicle is turned off.
There is still vacuum in the actuator.

What next?

Rod
.
mowerman
 
Posts: 13
Joined: Fri Mar 04, 2016 4:09 pm

Re: 4wd Light flashing while engaged

Postby Roguegir on Mon Feb 26, 2018 11:33 am

I had the same issue, drove me insane. I had a blown solenoid which I replaced but still had dramas with the constant dis-engaging.
Ended up wiring a dedicated switch to the solenoids. Fixed everything.

So it is something to to with the switch in the gearbox that is getting old. Thought it was too much work to get at it to fix it. No room really to get your hands around it.

Sent from my SM-G930F using Tapatalk
Roguegir
 
Posts: 44
Joined: Sat May 21, 2011 3:42 pm

Re: 4wd Light flashing while engaged

Postby mowerman on Mon Feb 26, 2018 3:50 pm

Thanks.
May I ask how is the switch wired to the solenoids?
And does that give you a constant flashing green lights in 2wd?

Rod.
.
Now I have a 2413 fault code.Egr.
Jeez.
mowerman
 
Posts: 13
Joined: Fri Mar 04, 2016 4:09 pm

Re: 4wd Light flashing while engaged

Postby Roguegir on Mon Feb 26, 2018 4:44 pm

I connected to the the wires right near the solenoids and run it up. Made sure I connected it to ignition power so it turns off when you turn off the car.
No flashing lights unless you switch it before moving the transfer lever.

i.e Move lever from 2h to 4h then flick the switch.

Light only flashes when you forget to flip the switch.

Sent from my SM-G930F using Tapatalk
Roguegir
 
Posts: 44
Joined: Sat May 21, 2011 3:42 pm

Re: 4wd Light flashing while engaged

Postby mowerman on Mon Feb 26, 2018 7:19 pm

I think I've got it.
The switch is only wired to the blue blob solenoid?

Rod
.
Nope.
Further reading and wired to both.
Both on 2wd, both off 4wd.
mowerman
 
Posts: 13
Joined: Fri Mar 04, 2016 4:09 pm

Re: 4wd Light flashing while engaged

Postby fireball on Wed Apr 11, 2018 9:03 am

So my 2008 ML is run into the flashing 4wd light problem.
Reading the thread I've found the rubber bung things people are talking about.
https://i.imgur.com/zMAGppy.jpg

Is the left one supposed to look like that?
It Wasn't dirty in the rubber bung.

So my problem is the light is flashing whilst in 2wd mode and when I turn the steering wheel i hear bad clunking and grinding from the front diff and it sometimes is really hard to turn the wheel. This might be compounded by the fact I have a front Lokka diff auto locker.

Tried going in reverse full lock but it's still flashing.

4H and 4L still works ok.

Where are these solenoids that I might have to replace??

Looking at the lines to the front diff actuator seem intact
https://i.imgur.com/qphyagW.jpg
User avatar
fireball
 
Posts: 164
Joined: Thu Mar 06, 2008 3:00 pm
Location: brisbane, QLD

Re: 4wd Light flashing while engaged

Postby JP84 on Fri Apr 19, 2019 4:12 pm

could anyone tell me how much movement you should expect to see in actuator when switching drive modes? for example is it only a few mm..? cheers
JP84
 
Posts: 3
Joined: Sun Apr 14, 2019 11:28 pm

Re: 4wd Light flashing while engaged

Postby brucewoodworker on Mon Aug 26, 2019 6:31 pm

JP84 wrote:could anyone tell me how much movement you should expect to see in actuator when switching drive modes? for example is it only a few mm..? cheers

It moves about 20mm.
brucewoodworker
 
Posts: 5
Joined: Thu Apr 30, 2015 7:40 pm

Re: 4wd Light flashing while engaged

Postby PixelPaul on Sat Apr 24, 2021 7:55 am

so i am having a flashing 4wd light now. yay.
when it is in 2WD the light keeps flashing, yet if i select 4WD H, it goes solid, tho i cant hear it change ( i use to be able to hear it), but it does drive like its in 4H. Selecting back to 2WD and it just keeps flashing no matter what i do. I did recently do an intake manifold clean so maybe a nocked something?
The rubber caps seemed okay, and when i take them off i can hear it suck in so there much be no leaks. What else should i check? i cant see any lines anywhere that are disconnected or cracked, tho i am not to sure which lines i should be focusing on. Where is the sensor located that i can clean/replace?
PixelPaul
 
Posts: 18
Joined: Sun May 04, 2014 6:47 pm

Re: 4wd Light flashing while engaged

Postby FQCODEL on Fri Apr 30, 2021 9:43 am

Does the front diff actuator require grease or something? I had a look under the boot and its bone dry.
FQCODEL
 
Posts: 6
Joined: Sun Apr 04, 2021 9:19 am

Re: 4wd Light flashing while engaged

Postby RHKTriton on Sat May 01, 2021 8:54 am

Wouldn't hurt to wipe a light coat of moly grease over the shaft. Just ensure that not a spec of dirt gets in there.

May also be worth checking your diff oil level.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4557
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Previous

Return to Drive Train Components

Who is online

Users browsing this forum: No registered users and 2 guests