Turns over but wont start 2.5 MN

Petrol, gas, fuel tanks etc

Turns over but wont start 2.5 MN

Postby Pinchers on Sat May 09, 2020 3:56 am

Im scratching my head with this one and hoping someone can help.

I've looked through similar posts but no luck.

So basically the truck is stranded at work and I need to get it moving soon.

When the fault happened I was leaving work, everything seemed ok with no odd noises.

I had been driving for about 2 mins and accelerating up to about 30mph, there was 2 quick hesitations/loss of power and then the engine stalled, while coasting there was a rotating grinding noise for about 2 seconds but this could have been me trying to restart it while coasting.

so now it cranks but won't fire, feels like there is no fuel or pressure. There's no EML codes.

I had done some work on it recently which could be causing the fault. :shock:

I had fitted a new fuel filter about 2 weeks ago, doubt this is the problem. No leaks and the system pumps up hard by hand.

I'd also fitted an upgraded SCV valve the week before and have only done a couple of short trips, I also haven't done a SQL relearn yet. After fitting, it started and idled fine, when driving it wouldnt go above 3K rpm but i put that down to needing a relearn.

Im going to fit the old SCV valve and see what happens, if no luck with that I will start proving that theres pressure at the rail etc.

Anyone else experienced anything similar
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am


 

Re: Turns over but wont start 2.5 MN

Postby RHKTriton on Sat May 09, 2020 9:54 am

Checked the plugs? :lol:

Filter or/ and SCV are the likely culprits. More likely SCV.

I would say you've possibly got a dud SCV and it's not allowing fuel to the high pressure pump.

With the filter, just make sure the gasket and 'o' ring are seated well.

I use the original and an extra worm drive hose clamp on each hose to make sure there are no leaks.

Once you're happy with these and you still have issues, I'd check the connector on the SCV.

See how you go.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4468
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Re: Turns over but wont start 2.5 MN

Postby DaveXT on Sat May 09, 2020 4:58 pm

I think I would pull the filter out and check it, it seems to be related.
DaveXT
 
Posts: 76
Joined: Sun Apr 04, 2010 6:20 pm

Re: Turns over but wont start 2.5 MN

Postby peter9231 on Sat May 09, 2020 7:15 pm

Check the cam belt.
User avatar
peter9231
Platinum Subscriber
 
Posts: 10
Joined: Thu Feb 02, 2017 5:17 pm

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Sun May 10, 2020 6:14 pm

Ive got a replacement SCV on order so i will give that a go next, i might pop the inspection cover off the timing belt and check its still there but i think that side of things is ok.
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Mon May 11, 2020 5:02 am

When i was working on it i was checking the pump fuel spill back line and hi pressure line to the rail, when the engine was turning over i had no or very little fuel at the hi pressure line and loads going back to the tank on the spill back line.

If the Mits SCV's are normally open there should be fuel getting to the hi pressure side of the pump? what internals of the fuel pump determines what goes back on the spill back to the tank?
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby RHKTriton on Mon May 11, 2020 7:52 am

Doubt it'd be the timing belt, as there's be at least a few valves smashing into pistons.

Not totally sure, but there maybe around strainer on the high pressure pump intake.

Timeframes you've described still points to SCV and filter.

REM. SCV controls the high pressure pump output.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4468
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Tue May 12, 2020 4:41 am

Had the SCV out again and did an electrical test on it with the battery to check it moved which it does, while it was out i tried pumping the fuel primer, there was no/very little fuel coming out the SCV hole, I saw a video on youtube of another car showing fuel spraying out the SCV hole when pumping the primer, im now thinking the filter might be choked somehow, filter has only been in 3 weeks. Forgot to pop off the supply pipe to the pump and double-check, I will give that a go tomorrow. seems doubtful the way it stalled initially with no warning.
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Thu May 14, 2020 1:38 am

I'm almost out of ideas with this and at a stage of removing the pump and stripping it down. Does anyone know if the Denso HP3 pumps are known for any mechanical failures?
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby RHKTriton on Thu May 14, 2020 8:29 am

Just recap the sequence of things you did leading up to your problem. One thing, you haven't stated how many KMS and age of vehicle.

I had a read through one of the manuals and it suggests a pump relearn needs to be done after SCV replacement ( never heard of or done one of these.

List of things to go over;

Double check that the fuel filter is actually the correct unit.

You might have coincidentally sucked up some crap out of the tank when a new filter was fitted.

SCV should measure around 2.1Ohm a across the coil.

Did you make the area around the SCV pristine before removing it? This task is almost like heart surgery.

Pulling the up pump apart should be the very last thing you do.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4468
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Re: Turns over but wont start 2.5 MN

Postby SLIMaxPower on Thu May 14, 2020 2:56 pm

fuel rail
User avatar
SLIMaxPower
Platinum Subscriber
 
Posts: 495
Joined: Thu Nov 27, 2014 10:56 am

Re: Turns over but wont start 2.5 MN

Postby Intruder on Thu May 14, 2020 5:38 pm

This may help with the fault finding.

https://www.service-engine.com.ua/webro ... ENGINE.pdf
Yes... I'll have another beer.
Intruder
Platinum Subscriber
 
Posts: 46
Joined: Thu Jan 10, 2013 5:29 am
Location: Hobart, Tasmania

Re: Turns over but wont start 2.5 MN

Postby DibbyDibbyDJ on Thu May 14, 2020 6:04 pm

Checking fuel pressure would be high on my first checks. cheap data reader should be able to cope. 20 - 30 mpa would be a good starting value
White 2018 MQ Sportsbar Nudge bar, Towbar, EDS
DibbyDibbyDJ
 
Posts: 127
Joined: Mon Oct 07, 2019 8:16 pm

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Fri May 15, 2020 2:14 am

Ok so the truck is a 2010 at nearly 200,000K

Fuel filter is right and i've proven fuel is coming out of the supply pipe feeding the back of the pump when operating the primer on the filter. Also when cranking the engine all the fuel seems to be going back down the spill backline to the tank.

I measure the resistance on the SCV im getting about 2,0 from memory also witnessed moving with voltage on it.... and that's 3 SCV I've tried now, 2 short bodies and one long with adapter kit on it. Area around SCV port always clean when working on it.

Ran some software on the computer via the obd port, got a reading on the fuel pressure when the engine was cranking and it got a reading of 370kPA, 60kPa when off.

I really dont want to take the pump out or open it up so all im left with is a SQL but from what ive read the engine needs to be idling when this is happening, i can even get mine to start :(
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby irwazza on Fri May 15, 2020 4:50 am

Something I can remember happening to my brother many years ago on a rodeo. We installed a chip and a hi spec fuel limiter. As soon as the limiter was installed it would turn over all day without starting. Put the standard one back in and it would start straight away. Got the hi spec limiter replaced with a new one and it started perfectly.
Not saying this is your issue but it’s something that I have seen with a faulty fuel limiter.


Sent from my iPhone using Tapatalk
User avatar
irwazza
 
Posts: 615
Joined: Sun Jul 10, 2011 9:07 pm

Re: Turns over but wont start 2.5 MN

Postby DibbyDibbyDJ on Fri May 15, 2020 6:10 am

So your fuel pressure is low.
Try clamping off the return hose to restrict flow back to the tank. Then check fuel pressure again.
White 2018 MQ Sportsbar Nudge bar, Towbar, EDS
DibbyDibbyDJ
 
Posts: 127
Joined: Mon Oct 07, 2019 8:16 pm

Re: Turns over but wont start 2.5 MN

Postby SLIMaxPower on Fri May 15, 2020 12:50 pm

fuel rail...
User avatar
SLIMaxPower
Platinum Subscriber
 
Posts: 495
Joined: Thu Nov 27, 2014 10:56 am

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Sat May 16, 2020 1:40 am

What could it be on the fuel rail? I did crack the bleed back line from the relief valve and there was no fuel blowing past when cranking the engine, might double check this though and if it was the pressure sensor i guess it would through a code.
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby irwazza on Sat May 16, 2020 6:00 am

The fuel limiter


Sent from my iPhone using Tapatalk
User avatar
irwazza
 
Posts: 615
Joined: Sun Jul 10, 2011 9:07 pm

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Sat May 16, 2020 6:47 am

why so much fuel spilling back from the pump if its the rail fuel limiter?
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby irwazza on Sat May 16, 2020 6:51 am

The fuel rail limiter may be the reason it is returning so much....


Sent from my iPhone using Tapatalk
User avatar
irwazza
 
Posts: 615
Joined: Sun Jul 10, 2011 9:07 pm

Re: Turns over but wont start 2.5 MN

Postby Pinchers on Fri Jul 10, 2020 4:14 am

Still playing about with this, pulling the fuel pump at the weekend. Im thinking its either the plungers on the high pressure side, fuel pressure regulator built into the pump or delivery valves on the pump that have failed.
We will see.
Pinchers
 
Posts: 25
Joined: Wed Apr 27, 2016 2:14 am

Re: Turns over but wont start 2.5 MN

Postby aids84 on Fri Jul 10, 2020 7:34 am

Sounds to me like an injector could be your problem. A stuck injector can allow excess fuel to spill through the return line and prevent fuel rail pressure building while cranking. With the symptoms you're describing that would be the first place I would look.

A high end scan tool should be able to look at the SQL values for the individual injectors, a dodgy injector will stand out pretty obviously in those values. Unfortunately due to the design of the return piping it is impossible to check them physically like on the 4N15.
User avatar
aids84
Platinum Subscriber
 
Posts: 258
Joined: Sat Aug 04, 2012 1:52 pm

Re: Turns over but wont start 2.5 MN

Postby Ricky on Fri Jul 10, 2020 8:01 pm

Crank angle sensor will not throw up a fault code.
Ricky
 
Posts: 40
Joined: Tue Nov 17, 2015 7:52 pm
Location: Brisbane

Re: Turns over but wont start 2.5 MN

Postby Ricky on Fri Jul 10, 2020 8:10 pm

Sorry, missed your post about your fuel pressure reading.

That low a reading would point to the pressure limiter in the end of the rail being stuck open, but that should throw up a low fuel pressure code.
Ricky
 
Posts: 40
Joined: Tue Nov 17, 2015 7:52 pm
Location: Brisbane

Next

Return to Fuel Systems

Who is online

Users browsing this forum: No registered users and 1 guest