SLIMax's Break It and Build It Thread

Want to show off what you've done to your rig? or have a custom project to show? Post it up here!

Re: SLIMax's Break It and Build It Thread

Postby SLIMaxPower on Wed Aug 01, 2018 11:31 am

Burnt through my bendix 4wd pads with 1mm left.

Anything better to get.

Powered by MaxPower
User avatar
SLIMaxPower
Platinum Subscriber
 
Posts: 499
Joined: Thu Nov 27, 2014 10:56 am


 

Re: SLIMax's Break It and Build It Thread

Postby SLIMaxPower on Fri Aug 03, 2018 2:52 pm

Bad to worse. The slotted rotors that were installed at the same time are fuxoured as well.

Aftermarket crap :(
User avatar
SLIMaxPower
Platinum Subscriber
 
Posts: 499
Joined: Thu Nov 27, 2014 10:56 am

Re: SLIMax's Break It and Build It Thread

Postby BillMcQuade on Sat Aug 04, 2018 2:03 am

SLIMaxPower wrote:Bad to worse. The slotted rotors that were installed at the same time are fuxoured as well.

Aftermarket crap :(


I use the RDA slotted rotors, and also use the pads that are supplied with them (RDA brand). In my experience, they are quite good. The pads are not as long lasting as Bendix, but they don't eat the rotors. The pads take a lot of abuse before they start to fade.
White 2013 MN GLX+ manual

"Tuned by Doctor Diesel"
User avatar
BillMcQuade
Platinum Subscriber
 
Posts: 2007
Joined: Sun Jun 23, 2013 12:20 pm
Location: The 'Gong

Re: SLIMax's Break It and Build It Thread

Postby SLIMaxPower on Wed Apr 07, 2021 6:00 pm

I have noticed while driving - under heavy load, mainly towing I can hear the engine revving higher 2200+ when I accelerate but no actual increase in acceleration as I have had previously.

There isn't any smoke, and if I back off some it seems normal.

Dropping back a gear works fine.

Don't know how else to explain it.

Cruise control drops out when it happens causing a shudder

I have had a new turbo, new exhaust, new chip, smaller wheels..

This has been happening for a good year and am now stumped with th4e cause.

Sent from my SM-G780F using Tapatalk
User avatar
SLIMaxPower
Platinum Subscriber
 
Posts: 499
Joined: Thu Nov 27, 2014 10:56 am

Re: SLIMax's Break It and Build It Thread

Postby RHKTriton on Fri Apr 09, 2021 8:04 am

Assuming you've got a manual and seeing what's been replaced, it seems the one item overlooked is the clutch.

My ml showed similar symptoms for a while, until third gear started slipping up hills.

Final warning to fix clutch. lol.
Don't let the b'strds get you down!!
RHKTriton
Platinum Subscriber
 
Posts: 4608
Joined: Wed Jun 10, 2009 10:05 pm
Location: La trobe Valley - Gippsland

Re: SLIMax's Break It and Build It Thread

Postby SLIMaxPower on Tue Aug 31, 2021 5:12 pm

Nearly 5 years to the day my new gearbox has lost the main shaft bearing with the shaft flopping and crunching on the cluster :(
User avatar
SLIMaxPower
Platinum Subscriber
 
Posts: 499
Joined: Thu Nov 27, 2014 10:56 am

Previous

Return to Member Build Ups

Who is online

Users browsing this forum: No registered users and 2 guests